Open Mind Logo

Contents

Introduction

This document provides instructions for Open Mind 5. This document is distributed with Open Mind and is also available on the Open Mind website.

If you have any feedback of suggestions for improvement regarding this documentation, or Open Mind in general, please contact us via our website: https://openmindsoftware.org/support

Terminology

The following terminology will be used in this documentation:

Term Description
Canvas The working area where the diagram is produced. Bubbles and connections can be arrange in this space by clicking and dragging them.
Bubble A single shape that can contain text and images. A bubble can be moved, resized and formatted as desired.
Document Each diagram being made belongs to a document.
Connection Bubbles can be connected together with a line. Each connection can be individually formatted and styled.
Bubble Toolbar The toolbar at the top of the screen that provides options for formatting and styling bubbles.
Theme Themes can be used to format bubbles and connections based on a pre-defined style.
Attach Bubbles can be 'attached' to other bubbles using a connection.

User Interface

As with previous versions of Open Mind, the user interface has been kept simplistic and intuitive to use. Users who are transitioning from older versions should feel at home straight away. An important significant difference is the ability to work on multiple documents simultaneously by switching tabs.

The Open Mind user interface

Creating a Document

You can create a new document by clicking the File menu and selecting New. Alternatively, you can click the new document icon on the toolbar or use the ctrl + n shortcut key. Multiple documents can be worked on simultaneously by switching between them using the tabs below the toolbar.

Saving and Opening Documents

Open Mind introduces a new file format, however any documents produced in older versions are fully compatible with version 5. To save a document click the File menu and then click Save or Save As. The shortcut key ctrl + s can be used to quickly save a document. The saved document can be opened on any computer with Open Mind 5 or higher.

A document can be opened by clicking File and selecting Open. The ctrl + o shortcut key can also be used.

Encrypted Documents

Documents can be encrypted using 256-bit AES encryption, one of the most secure encryption technologies available. Password protection can be set by going to File and clicking Password protection, you will be asked to enter a password and then to confirm it. Password protection can be removed by clicking the Password protection menu item again. When attempting to open a password protected document, you will be required to re-enter this password to decrypt the document. Be careful using this feature, if the password is forgotten the work will be unrecoverable.

The password protection dialogue

Importing

Open Mind files can be imported into a currently open document to merge the two together. Going to File and clicking Import will open a dialogue asking you to browse for an Open Mind file. Both encrypted and unencrypted files can be imported, however if the document is encrypted you will be required to enter the password.

Exporting

An Open Mind document can be exported to multiple common file formats and application specific formats. Export options include Image, Portable Document Format (PDF), Scalable Vector Format (SVG) and Microsoft XPS format. Exporting a file is the best way to send your document to someone who does not have Open Mind.

Format Explanation
Image (Jpeg, Png, Gif, Bmp) Suitable for including a diagram in other places such as on a website or in a presentation.
PDF or XPS The best format for sending a document to someone who does not have Open Mind.
SVG Most suitable for printing at high resolutions (such as posters).

The various export options available

Dropbox

Dropbox is a free secure cloud storage solution. Any Open Mind document can be saved directly to your Dropbox account by going to File, Dropbox and then clicking Save. If you have not linked Open Mind to Dropbox yet, you will be prompted to login and approve the Open Mind app. Once you have done this, you will be able to save and retrieve documents from the cloud.

The open from Dropbox dialogue

Printing

Any Open Mind document can be printed. Click on File and Print (or ctrl + p) to open the system print dialogue. All documents are clipped of white space so only the bubbles are included. If page guides have been configured (see next section) then the paper size will be set to match the guides.

Page Guides

Page guides can be used to show the boundary of various paper sizes for a document. They are not included in exported or printed versions of a document, they simply provide an indication of where the page boundaries are. By default page guides are not enabled, they can be selected by going to View and clicking Page guides. This will show a list of various paper sizes and orientations that can be chosen.

The page guide options available

Edit and Undo

A new feature in Open Mind 5 is the ability to undo and redo any action. As with most applications that support this, the keyboard shortcuts ctrl + z and ctrl + y can be used to undo and redo respectively.

Find and Replace

The find and replace dialogue is used to search the current document for a phrase or word. It can be opened by clicking Edit and then Find. Alternatively, the keyboard shortcut ctrl + f can be used. The search phrase should be entered in the 'Find what:' box and then the search can be ran by clicking Find. Matching bubbles and connections will be highlighted in red to indicate they match the search phrase.

The search phrase can be replaced with something else by entering the replacement phrase in the 'Replace with:' box and clicking Replace All. This will replace all occurrences of the search phrase with the replacement phrase.

The find and replace dialogue

Spell Checker

The spell checker can be ran by going to Tools and clicking Spelling. This will launch a spell check dialogue that will scan the currently open document for incorrectly spelt words. Incorrect spellings will be marked in red text and some suggestions will be listed below. To replace the word with the correct spelling, select the suggestion and click Change. If you believe the spelling is correct, you can add it to the dictionary by clicking Add. If you want to ignore the error, click Ignore.

The spell checker dialogue

To change the spelling language, open the spell checker and select the language required from the drop down menu at the bottom of the dialog. The spell checker will need to be closed and reopened for the change to take effect.

Open Mind provides spelling dictionaries for different languages. These are available to install as an optional extra. If you only have one language available, you will need to run the Open Mind installer again and select the optional spelling dictionaries. An internet connection will be required to download the dictionaries.

The additional spelling dictionaries option in the installer

Zooming and Panning

Often you will need more space than what is immediately available on the screen. The document can be zoomed in and out by using the magnifying glass icons in the toolbar. The dropdown list next to them indicates the current zoom level percentage. The mouse scroll wheel can also be used to zoom in and out of a document.

The zoom toolbar items

The same zoom options are available in the View menu. There is an option to reset the zoom level by clicking View and selecting Reset. You can also select Fit on screen to see the entire document on the screen.

The View menu options

Bubbles

Creating Bubbles

There are several ways to create a new bubble. The easiest way is to right click on some empty space in the document and click 'New bubble'. You can duplicate or directly attach another bubble by right clicking an existing one and clicking Duplicate or Add bubble.

The right click menu for a bubble

Alternatively, you can paste an image or some text directly into Open Mind (by going to Edit and clicking Paste) which will automatically place the content inside a bubble. You can copy and paste bubbles directly as well using keyboard shortcuts ctrl + c and ctrl + v.

Resizing and Moving Bubbles

Bubbles can be moved by simply clicking and dragging them using the mouse. Multiple bubbles can be moved together by holding the ctrl key and clicking each bubble. The selection group can then be dragged using the mouse. Alternatively, the keyboard arrow keys (, , , ) can be used to move the selection.

A selected bubble has a wireframe border around it which has 8 small square buttons, these buttons can be clicked and dragged to resize the bubble. You may need to resize a bubble in order for all the text to be displayed properly.

A selected bubble with wireframe around it

Editing Bubble Text

The text inside a bubble can be edited by double clicking a bubble. This will open a text editor that allows you to type text into the bubble. The bubble editor has formatting options for changing the font, text color, text size and alignment. To change the format of some text you must first select it with the mouse cursor and then choose the formatting option from the editor menu. Clicking anywhere on the screen will close the text editor.

The bubble text editor

Styling Bubbles

There are many options for styling bubbles. The styling options become available in the toolbar when a bubble is selected.

Option Explanation
Shape picker Change the shape of the bubble from a selection of over 70 shapes.
Fill color Change the fill color of the bubble.
Fill gradient Change the gradient fill style of the bubble. Defaults to a solid fill.
Border color Change the border color of the bubble.
Border thickness Change the thickness of the bubble border.
Border style Change the style of border.
Image selector Add or remove an image from the bubble.

Adding Images

It is possible to include images in your document by adding one to a bubble. Select a bubble, click the image icon in the toolbar and browse for the image you want to include. The image will appear inside the bubble. You can resize the bubble to make the image the size you want.

An image can be removed by either deleting the bubble, or by selecting the bubble and clicking the same image icon in the toolbar.

Connections

Creating a Connection

Two bubbles can be connected to each other by right clicking on one bubble and clicking Attach. Click on the bubble which you wish to connect the bubble to. This will create a connection between them both.

Creating connection

Connection Styles

The style or type of connections can be changed by right clicking a connection and selecting a style. There are 5 styles available; straight, dashed, smooth, trunk and flowchart. The straight, dashed and flowchart styles can have an arrow by selecting the Arrow option in the connection right click menu. The color and size of the connection can also be changed in this menu.

Connection right click menu

Connection Labels

A label can be added to a connection by right clicking it and selecting Label. A text editor will open that allows you to enter some text. Click anywhere in the screen to close the editor and apply the changes.

Connection label editor

Connection with a label

Changing Background Color

The background color of the document can be changed by right clicking an empty space and clicking Background. This will display a color picker that allows you to select a color to use.

Background color picker

Themes

Themes are a quick way to apply a uniform style to a diagram. Open Mind comes pre-installed with twelve themes for you to choose from, however you are able to easily create your own themes. You can choose to apply a theme to a selection of bubbles or an entire document. To apply a theme to a selection, simply make the selection and then go to the Themes menu and select the theme you want. A theme can be applied to a whole document by not selecting anything and clicking on a theme.

Available themes

Creating a Theme

It is possible to create your own themes. You must first create a document and style the bubbles and document to the style you want your theme to have. Then click on Themes and select Create. This will open a dialogue that lets you name your new theme. The theme will be created and will automatically assume the style of the document.

Create theme dialogue

Auto Layout

New to version 5 is the ability to automatically arrange the layout of a diagram by pressing a single button. Open Mind provides three styles of layout 'Tree', 'Condensed' and 'Spacious' which can be applied by clicking Tools and then Auto Layout. Each style has it's own characteristics that will suit some diagrams but not others, so it is recommended to try each type of layout and pick the one which looks the best.